emcli add_mp_to_mpa reports ‘target type metadata version is improperly formatted’


While creating your own Enterprise Manager Grid Control Management Plugin using a statement like this :


emcli add_mp_to_mpa –mpa="jar_filename.jar" –mp_version="Version_in_Metadata" –ttd="metadata.xml" –dc="default_collection.xml"

You might run into this error


Error: The target type metadata version is improperly formatted. It must consist of two dot (.) separated numbers, with total length at most 8 characters.

Please check your metadata.xml file and use that version in mp_version.
(So META_VER=”1.3″ should match -mp_version=”1.3″ )